Delphi: Application does not support this device

Задача: Создал маленькое приложение которое использует технологию App Tethering для передачи сообщений между приложениями, но при первом запуске приложения на телефоне — возникла ошибка:

Application does not support this device

Инструментарий:  Delphi XE8, Android 4.0.3 (телефон Acer Liquid Gallant Duo E350)
Решение: При попытке запустить приложение под управлением Android 4.0.x или Amazon Kindle Fire иногда возникает ошибка

Application does not support this device

Временным решением данной проблемы для платформ Android 4.0.x и Amazon Kindle Fire будет:

  1. В Delphi IDE нужно открыть Deployment Manager (Project > Deployment)
  2. Снять галочку напротив пункта со следующими значениями:
    • Local Name: libnative-activity.so
    • Remote Path: library\lib\armeabi\
  3. Пересобрать проект (Project > Build (Shift+F9)):

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *